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Repeat markers for SmartMusic 
accompaniments 
In SmartMusic, the number and iteration of each repeated section is displayed on the main interface window during the 
SmartMusic performance as shown below: 

  

You can add markers in Finale to indicate these repeated sections for display during the performance, including 
repeats with multiple endings, as well as DS and DC repeats.  

To Add Repeat Markers Automatically 
In most cases, the following steps are not necessary to incorporate repeats into your SmartMusic accompaniment. 
However, you can preview the automatically generated repeat markers prior to saving your file by following these 
steps. 

1. Add repeat barlines and text indications as describ ed in the Repeat Tool chapter.  Add any type of repeat you 
like, first and second endings, D.S. al Coda, etc.  

2. From the Document menu, choose Add SmartMusic Marke rs. The Add SmartMusic Markers dialog box 
appears.  

3. From the List on the left, choose Repeats.     

4. Click Create/Update Repeat Markers. The score is scanned for all repeat indications. The list of repeat markers 
appears in the main window.  

5. Click Done. All repeat markers have been added to your score automatically based on the repeat barlines and 
markings.  

If you want more control over SmartMusic Repeat Markers, or want to edit the ones created for you automatically, you 
can also add/edit them manually with the Expression Tool as described below. 

To Add Repeat Markers Manually as Expressions 
Repeat markers can be added to the Finale score as expressions like the other SmartMusic markers. Unlike other 
markers, these require additional parameters to specify the number of the repeat (i.e. the first, second, third, etc. 
repeated section in the score), the iteration of te repeat and the measure number. For general information on adding 
SmartMusic markers, see To add SmartMusic Performance Markers. 

If repeats are already defined in a score for playback, you can easily convert the file to a through composed format by 
exporting it as a MIDI file, and then importing the generated MIDI file back into Finale. Repeated sections are then 
written out sequentially. Since all playback data is saved with MIDI files, information relevant to SmartMusic 
accompaniment creation is not lost in this conversion. See MIDI files for details. If you do this, ensure the solo staff is 
assigned to a different channel than the accompaniment staff(ves) in the Instrument List window. 

Here is a list of the types of repeat markers, where to add them, and how they are defined for different types of 
repeated sections. To use pre-defined repeat marker expressions, load the SMS Markers library.From the File menu, 
choose Load Library, and then double-click “SMS Markers”. 

An expression defined as a Repeat  marker is required to mark the beginning of each iteration (or pass) of a repeated 
section of music. Additional numbers are then added to the Description text box in the Expression Designer to indicate 
the following: 

Page 1 of 9Repeat markers for SmartMusic accompaniments

3/25/2010http://www.finalemusic.com/UserManuals/Finale2010Win/Content/Finale/Repeat_Markers_for_S...



r,t,m 

r = Repeat number (starting with 1 on the first repeat pair and increasing by 1 for each successive pair). 

t = Time through the repeat. 1 for first iteration, 2 for second, etc.  

m = Measure number of the repeat in the original score. This number should be the same for each iteration of a repeat 
(even though the measure number in the through composed Finale document may differ). 

Example: 

This Repeat marks the location in the Finale document of the third repeated section, beginning at the second iteration. 
This appears at the beginning of measure 12 in the original Finale score. An expression containing this SmartMusic 
marker would appear at a later measure in the modified (through composed) Finale document. 

If there are multiple endings in a repeated section (first ending, second ending etc.), an expression defined as a 
Repeat Ending  marker is required to mark the beginning of each ending. For these markers, the following parameters 
are then added to the Description text box in the Expression Designer to indicate the following: 

r,m 

r = Repeat number. 

m = Measure number of the ending in the original score.  

Example: 

This Repeat Ending marks the location in the Finale document of an ending for the first repeat. This appears at the 
beginning of measure 3 in the original Finale score. (The ending number is not required).  

If there is a Dal Segno repeat in the original score, an expression defined as a Repeat DS  marker is required to mark 
the first pass of the Segno (sign), the actual D.S. section, and the end of the D.S. section. For these markers, the 
following parameters are then added to the Description text box in the Expression Designer to indicate the following: 

d,f,m 

d = Dal Segno number (starting with 1 for the first D.S. and increasing sequentially for each D.S section. 

f = Flag to denote whether this marks the location of the Segno (sign) going by the first time (f=1), the actual beginning 
of the D.S. section (f=2), or the end of the D.S. section (f=E) 

m = Measure number of the location in the original score.  

Example: 

This Repeat DS marks the location in the Finale document of the ‘actual beginning’ of the first DS section. This 
appears at the beginning of measure 3 in the original Finale score.  

If there is a D.C. repeat in the original score, an expression defined as a Repeat DC  marker is required to mark the 
beginning of the score, the ‘actual beginning’ of the D.C. section, and the end of the D.C. section. For these markers, 
the following parameters are then added to the Description text box in the Expression Designer to indicate the 
following: 

d,f,m  
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d = D.C. number. 

f = Flag to denote whether this marks the location of the beginning D.C. (f=1), the actual beginning of the D.C. section 
(f=2), or the end of the D.C. section (f=E) 

m = Measure number of the location in the original score.  

Example: 

This Repeat D.C. marks the location in the Finale document of the ‘actual beginning’ of the first DS section. This 
appears at the beginning of measure 3 in the original Finale score.  

On the first beat following the last iteration, an expression defined as a Repeat End  marker is required to mark the 
completion of the repeated section and establish the measure to continue from in SmartMusic. The following entries 
are required in the Description section of the Expression Designer for a Repeat End marker to indicate the following: 

r,E,m 

r = Repeat number (starting with 1 on the first repeat pair and increasing by 1 for each successive pair). This should be 
the same “r” value used for each of the prior iterations. 

m = Number of the measure, in the original score, following the repeated section. 

Example: 

This Repeat End marks the location in the Finale document of the ending of the fourth repeated section. This appears 
at the first beat of measure 16 in the original Finale document. This marker would appear at the first beat following the 
last iteration of the fourth repeat in the modified (through composed) Finale document. 

To add markers for repeats without endings as expre ssions 

1. Open the Finale document. If it already contains re peat bars, text repeats, or other repeat indication s that 
apply to playback, remove them.  If the music is through composed already, skip to step 3.  

Tip:  To remove all repeats in a document at once, select the Selection Tool. From the Edit menu, choose Select All (or 
press Ctrl-A). Then, from the Edit menu, choose Clear Items. Select Only Selected Items, choose Measures, check 
Repeats, and then click OK back to the score.  

2. Copy and insert music to reproduce the flow of the original playback. See Copying music for details.  

3. Choose the Expression Tool   .  
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4. On the solo staff (or the top staff of an ensemble score), double-click the first note of the first it eration of 
the repeat.  If there is not a note on the first beat of the section in the top/solo staff, double-click the measure. The 
Expression Selection dialog box appears.  

5. Click Create.  The Expression Designer dialog box appears.  

6. Type “Repeat 1” (optional).  This text will appear in the score as a reminder, though you could leave this box 
empty if you do not care to display any text in the score. If you do not enter any text here, skip the next step.  

7. Highlight the text, and then from the Text menu, ch oose Style > Hidden. Now, the expression is defined to 
appear in light gray in the score, and will not print.  

8. Click the Playback tab.     

9. From the Type drop-down menu, choose SmartMusic Mar ker.  The SMS Marker drop-down menu appears.  

10. From the SMS Marker drop-down menu, choose Repeat S tart.   

11. Choose the Text tab in the upper left.   

12. In the Description text box, separated by commas, t ype the values for r, t, and m . For example, if this is the 
first repeat pair in the score, first time through, starting on the first measure, you would enter the following:  

3. Click OK.  You return to the Expression Selection dialog box.  

4. Click Select.  The Expression Assignment dialog box appears.  

5. If you are assigning the marker as an Expression, i n the Expression Assignment dialog box, under Begin  
Playback at, choose Beginning of Measure.  

6. Click OK. The expression appears above the score. Now, we’ll add another expression to indicate the beginning 
of the second iteration of the repeat.  

7. On the solo staff (or the top staff of an ensemble score), double-click the first note of the second i teration 
of the repeat.  If there is not a note on the first beat of the section in the top/solo staff, double-click the measure. 
The Expression Selection dialog box appears.  

8. Click the expression you created for the first iter ation and then click Duplicate.  Since we just need to make a 
few changes to this expression, it is easiest to duplicate the one we’ve already made. The duplicate expression in 
highlighted automatically.  

9. Click Edit.  The Expression Designer dialog box appears. Here, in the main text editor, you can change the text if 
desired to indicate this is the second pass. For example, you might type “Repeat 1 pass 2.”  

10. In the Description text box, separated by commas, t ype the values for r, t, and m.  For example, if this is the 
first repeat in the score, second time through, starting on the third measure*, you would enter the following:  

Note*: The measure number (third entry in the description field) for the first and second iteration should always be the 
same, even though the measure number in the Finale score will be different (since the piece is through composed). 
This instructs SmartMusic’s measure counter to return to the first measure of the repeated section. To adjust Finale’s 
measure numbering to correspond to the repeated sections, you might want to adjust the measure number regions for 
your own reference. This can be particularly useful if there are many repeated sections. See Measure numbers. 

21. Click OK.  You return to the Expression Selection dialog box.  

22. Click Assign.  The expression appears above the score. A repeat marker should now appear at the beginning of 
each iteration.  
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. 

The image above shows a repeated section of music duplicated for compatibility with SmartMusic. A repeat marker 
expression appears on the first beat of each iteration. The numbers in parentheses show the values for r, t, and m (as if 
this example begins on measure 1). 

25. On the solo staff (or the top staff of an ensemble score), double-click the first note following the f inal 
iteration of the repeat.  If there is not a note on the first beat of the section in the top/solo staff, double-click the 
measure. The Expression Selection dialog box appears.  

26. Type “Repeat End 1” (optional).  This text will appear in the score as a reminder, though you could leave this box 
empty if you do not care to display any text in the score. If you do not enter any text here, skip the next two steps.  

27. Highlight the text, and then from the Text menu, ch oose Effects > Hidden. Now, the expression is defined to 
appear in light gray in the score, and will not print.  

28. Click the Playback tab.     

29. From the Type drop-down menu, choose SmartMusic Mar ker. The SMS Marker drop-down menu appears.  

30. From the SMS Marker drop-down menu, choose Repeat E nd.   

31. Choose the Text tab in the upper left.   

32. In the Description text box, separated by commas, t ype the values for r, and m (as described above under 
Repeat markers for SmartMusic accompaniments). For example, if this is the end of the first repeat, that continues 
on measure 3 of the original Finale score, you would enter the following:  

33. Click OK.  You return to the Expression Selection dialog box.  

34. Click Assign.  The expression appears above the score.  

You have completed defining a basic repeat for transfer to SmartMusic. Now, follow the instructions under SmartMusic 
to create the accompaniment SMP file. To create markers for repeats containing multiple endings, see To add markers 
for Ending repeats. To create markers for DS or DC repeats, see To add markers for D.S. and D.C. repeats.   

To add markers for repeats with endings as expressi ons 
The same basic procedure for creating basic repeats also applies to the creation of repeats with a first and second 
ending, only an additional Repeat Ending marker is required to mark the first beat of each ending. You can define as 
many endings as you like. Ending repeats do not appear in the Repeat window of the SmartMusic interface, but are 
required to accurately display the appropriate measure number in SmartMusic’s measure counter.  

1. Open the Finale document. If the document is already through composed without repeat markings, skip the next 
two steps.  

2. If the repeats are marked in the score, copy music from the opening repeat through the measure prior t o 
the first ending. Insert this music before the firs t measure of each ending (as shown below). See Copying 
music for details.  
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3. Remove the repeat bars and endings. The repeated section should now be through composed (to playback as if 
the repeats were still there).  

Tip:  To remove all repeats in a document at once, select the Selection Tool. From the Edit menu, choose Select All (or 
press Ctrl-A). Then, from the Edit menu, choose Clear Items. Select Only Selected Items, choose Measures, check 
Repeats, and then click OK back to the score.  

4. If it already contains repeat bars, text repeats, o r other repeat indications that apply to playback, remove 
them.   

5. Choose the Expression Tool y and add an expression defined as a Repeat marker o n the first beat of each 
iteration. Add the Repeat End marker on the beat fo llowing the final ending.  See To add markers for repeats 
without endings for instructions.  

6. On the solo staff (or the top staff of an ensemble score), double-click the first note of an ending (s tart by 
clicking the first ending).  If there is not a note on the first beat of the ending in the top/solo staff, double-click the 
measure. The Expression Selection dialog box appears.  

7. Type any desired text in the text editor window (e. g. “First Ending”) (optional).  This text will appear in the 
score as a reminder, though you could leave this box empty if you do not care to display any text in the score. If 
this was the second ending, you might type “Second Ending.” If you do not enter any text here, skip the next two 
steps.  

8. Highlight the text, and then from the Text menu, ch oose Effects >> Hidden.  Now, the expression is defined to 
appear in light gray in the score, and will not print.  

9. Click the Playback tab.     

10. From the Type drop-down menu, choose SmartMusic Mar ker.  The SMS Marker drop-down menu appears.  

11. From the SMS Marker drop-down menu, choose Repeat E nding.   

12. Choose the Text tab in the upper left.   

13. In the Description text box, separated by commas, t ype the values for r, and m  (as described under Repeat 
markers for SmartMusic accompaniments). For example, if this is the first ending of the first repeat, that starts on 
measure 3 of the original Finale score, you would enter the following:  

  

For the second ending of the repeat, add the number of measures in the first ending to establish the m value for 
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the second ending. For this example, if the first ending defined above were one measure long, you would type 
the following for the second ending. (This should be consistent with the original Finale document) 

  

  

14. Click OK.  You return to the Expression Selection dialog box.  

15. Click Assign. The expression appears above the score.  

16. Double-click the first note of the second ending, a nd then follow the last 12 steps for the second, th ird, or 
any additional endings.     

A repeat with a first and second ending properly defined for export as a SmartMusic accompaniment. The repeat and 
ending expressions are defined as Repeat markers and the final expression in the last measure is defined as a Repeat 
End marker. The values in parentheses are those that would appear in the Description text box of the Expression 
Designer. 

Now, follow the instructions under SmartMusic to create the accompaniment SMP file. 

To add markers for D.S. and D.C. repeats as express ions 

1. Open the Finale document.   

2. Copy and insert music to reproduce the flow of the original playback.  In the image below, the D.S. section, up 
to the fine, is inserted after the last measure. For a D.C., music from the beginning up to the fine marking would be 
inserted after the last measure. If there are sections enclosed in repeat bars, duplicate them first. See Copying 
music for details.  
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3. If the score contains repeat bars, text repeats, or  other repeat indications that apply to playback, r emove 
them.     

4. Choose the Expression Tool y and add Repeat markers for any repeat bars or endi ngs.  Add Repeat End 
markers at the conclusion of each repeat. See To add markers for repeats without endings and To add markers for 
repeats with endings for instructions.   

5. Add an expression defined as a Repeat DS marker on the first beat of the Segno (first time through). O r, 
add a Repeat DC marker at the beginning of the scor e. In the Description text box of the Expression 
Designer, enter the appropriate d, f and m values  (as described for Repeat DS and Repeat DC under Repeat 
markers for SmartMusic accompaniments). For example, if this is the first D.S., first pass, that starts on measure 3 
of the original Finale score, you would enter the following:  

  

If a Repeat DC or Repeat DS marker is required at the same point as a normal Repeat marker (that begins a 
repeat), place the Repeat DC/DS marker just to the left of the Repeat. To offset a marker by less than a beat, 
position the expression in the score accordingly, and then, in the Expression Assignment dialog box, for Begin 
Playback at, choose Position in Measure. 

6. Add an expression defined as a Repeat DS marker on the first beat of the actual Segno (that appears in  the 
measure after the D.S. marking). Or, for a D.C., ad d a Repeat DC marker on the first beat of the secon d 
iteration of the music (that was copied earlier). I n the Description text box of the Expression Design er, 
enter the appropriate d, f and m values.  For example, if this is the first D.S., second pass, that starts on measure 
3 of the original Finale score, you would enter the following:  

  

7. Add an expression defined as a Repeat DS marker on the first beat of the measure following the Segno 
section. Or, for a D.C., add a Repeat DC marker aft er the last beat of the music. In the Description t ext box 
of the Expression Designer, enter the appropriate d , f and m values.  For example, if this is the end of the first 
D.S., that ends on measure 5 of the original Finale score, you would enter the following:  
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If the last measure of the Segno section is the last measure of the score, enter an expression just to the right of 
the last beat of the measure. 

If a Repeat DS/DC end is required at the same point as a Repeat End marker, place the Repeat DS/DC marker 
just to the right of the Repeat End.  

The image below shows an example of a D.S. repeat with the appropriate SmartMusic Performance Markers. 
The values in parentheses are those that should appear in the Description text box of the Expression designer.  

Repeated sections are marked on the D.S. or D.C. even if the repeats are not played (for sections marked 
“repeat first time only” for example). In these cases, the Repeat marker should be set to “0” for the t (time) value 
in the Description text box of the Expression designer to signify that this is the only time through.  

The following chart shows an example of a D.C. al Fine. The top portion shows an outline of the original file. The 
bottom portion shows the through composed sequence and the correct positioning of repeat marker expressions 
for the D.C. al Fine.  

  

  

  

User Manual Home  
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